Check_drivesize virtual machine 87: The parameter is incorrect


#1

Hi, when I ran this command against a VMware Virtual Machine I got an error. -c Check_DriveSize “filter=type in (‘fixed’)” exclude=“System Reserved” ignore-unreadable

debug:c:\source\master\include\parsers\filter\modern_filter.cpp:10: Error: Failed to get size for \?\Volume{643862bb-ad41-11e0-ad76-806e6f6e6963}: 87: The parameter is incorrect.

I tried client 0.4.4.19 and 0.5.0.45


#2

I think this was fixed during summer… please check with latest 0.5.0 version and let me know how it goes…


#3

I check with the Version 0.5.0.55, but still the same.


#4

Hmm, ok…

Try using with the new filters:

mounted Check if a drive is mounted readable 1 (true) if drive is readable

i.e.:

Check_DriveSize "filter=type in (\'fixed\') and readable = 1 and mounted = 1" exclude="System Reserved" ignore-unreadable

If not, can you give me a way to simulate the problem? I.e. anyway I can create a similar drive?

// Michael Medin


#5

Here the Output: OUTPUT: Filter processing failed: Failed to get size for \?\Volume{643862bb-ad41-11e0-ad76-806e6f6e6963}: 87: The parameter is incorrect. I don’t know, how you could create a similar drive. With the old command I see know issues.

-c CheckDriveSize -a ShowAll MinWarn=12% MinCrit=8% FilterType=fixed On other virtual machine I also see now issues with the new command.


#6

Posting this in case it helps someone in the future. I still had this problem with version .67, although it was random and intermittent. I found a workaround by filtering by drive letter:

check_drivesize drive=all-drives "filter=drive in ('C:\', 'D:\', 'E:\', 'F:\', 'G:\')" warn=free<10% crit=free<4%

Edit: would you like me to update Bug #336, since it seems to be relevant to this issue?


#7

Please disregard my previous post. The filters posted by MickeM work fine on all of our servers except one. It’s a Veeam Backup proxy server. I took a closer look and found that when Veeam does a backup, it mounts a special kind of drive that cannot be accessed by even an Admin account. They disappear when the backup finishes. I tried to do a search on this behavior, I could look into the documentation for Veeam, but for the sake of my sanity, I’m going to just create an exception for this server, where it explicitely checks the C: drive alone.