Check_nrpe 3.2.0 and NSCP-0.5.0.62-x64 SSL handshake problem


#1

Hi I use Nagios Core 4.2.1 on Red Hat Enterprise Linux Server release 6.7 (Santiago) and I testing check_nrpe 3.2.0 client and NSCLIENT++ installed by package NSCP-0.5.0.62-x64.exe on windows 2008 environment

in the nsclient.ini I configured (on windows server)

[/settings/default] password = password allowed_hosts = NAGIO IP [/settings/NRPE/server] ssl options = verify mode = none [/modules] CheckExternalScripts = 1 CheckHelpers = 1 CheckNSCP = 1 CheckDisk = 1 CheckSystem = 1 CheckEventLog = 1 NSCAClient = 1 WEBSErver = 1 NRPEServer = 1

./check_nrpe -H 10.209.12.176 -g log.txt CHECK_NRPE: Error - Could not connect to 10.209.12.176: Connection reset by peer

and in the log I found [1498739822] Error: (nerrs = 0)(!log_opts) Could not complete SSL handshake with 10.209.12.176: rc=0 SSL-error=5

I did another command ./check_nrpe -H 10.209.12.176 -n -g log.txt CHECK_NRPE: Receive header underflow - only 0 bytes received (4 expected).

and in the log I found [1498808648] Remote 10.209.12.176 does not support Version 3 Packets [1498808648] Remote 10.209.12.176 accepted a Version 2 Packet

-n, --no-ssl Do no use SSL

If I did ./check_nrpe -H 10.209.12.176 -n --v2-packets-only I got the same message …CHECK_NRPE: Receive header underflow - only 0 bytes received (4 expected).

-2, --v2-packets-only Only use version 2 packets, not version 3

Please , could you help me to solve the problem ?


#2

That is not a valid config. Try this instead:

[/settings/default]
password = password
allowed hosts = xxxxxxx
[/settings/NRPE/server]
insecure = true
verify mode = none
[/modules]
CheckExternalScripts = 1
CheckHelpers = 1
CheckNSCP = 1
CheckDisk = 1
CheckSystem = 1
CheckEventLog = 1
NSCAClient = 1
WEBSErver = 1
NRPEServer = 1

#3

Now works !!!

The errore was in allowed hosts

I wrote allowed_host inster of allowed host (I used “_” and this is the error)

thanks Emilio