Check_nt useddiskspace invalid drive or invalid return from command


#1

Hello to all,

a bit strange thing here. I’ve got a centreon server polling about 20 Windows servers with check_nt. Servers are 2008 R2 to 2016, all is ok. On a new server I’ve got a C drive (system internal HD) and I’ve added for testing purpose an external USB E: drive. check_nt command return NSClient - ERROR: Invalid return from command: check_drivesize on C Correct results on E

I was using the last 5.x stable release of nsclient++ on this machine, so I’ve tried to downgrade to 4.x. Same error except the message is "invalid drive’ on older versions (4.1).

On the same server I check CPU and memory with no error (all nsclient++ version).

Any idea ?

Thks & Rgds,


#2

I would recommend using check_nrpe over check_nt.

That said how large are the drives? and what does check_drive_size give if you run in test mode?


#3

Hi, Thks for the answer. I plan to redo my centreon server and migrate to check_nrpe soon.

In test mode it’s crazy, the local checkdrive_size command return correct info but more strange, the cli from the centreon server works. As soon as I exit test mode and run as a service on Windows, error is back on centreon. The disk is just above 1.1 To.

check_drivesize L cli OK: OK All 3 drive(s) are ok L cli Performance data: ‘C:\ used’=0.57021TB;0.87105;0.97993;0;1.08881 ‘C:\ used %’=52%;79;89;0;100 ‘D:\ used’=0B;0;0;0;0 ‘\?\Volume{d047321f-046b-4a6d-b22c-77bcee5b069b}\ used’=316.4414MB;359.99687;404.99648;0;449.99609 ‘\?\Volume{d047321f-046b-4a6d-b22c-77bcee5b069b}\ used %’=70%;79;89;0;100 D check_nt Accepting connection from: ip_hidden exit