Increase timeout from commandline


#1

Hello,

when using nscp as a plugin from icinga2 agent i have sometimes a timeout message which comes from nscp. It goes away if i create a nsclient.ini with

[/settings/default]
timeout = 60

My question is, how can i increase timeout when calling the nscp.exe as plugin without the need of nsclient.ini?

For uptime icinga2 calls nscp like this

nscp.exe client --module CheckSystem -b -q check_uptime

NSCP version is 0.5.2.35

Thanks, Carsten


#2

There seems to be many different timeout settings in various locations. You can read up on the many timeout settings here: https://docs.nsclient.org/faq/#42-timeout-issues