Move to new monitoring Server: Could not complete SSL handshake


#1
Summary

This text will be hidden

Hi, I just set up a new monitoring server which should replace the old one. When trying to connect to the NSCLIENT I always get CHECK_NRPE: (ssl_err != 5) Error - Could not complete SSL handshake with 137.250.xxx.xx: 1 I already added the new server to allowed hosts. The connection to from the old server is still working, but the new one not. I already tried nearly everything I found on Google and here, without success. My config is:

    ; Undocumented section
[/modules]

; Undocumented key
CheckDisk = 1

; Undocumented key
CheckEventLog = 1

; Undocumented key
CheckExternalScripts = 1

; Undocumented key
CheckHelpers = 1

; Undocumented key
CheckNSCP = 1

; Undocumented key
CheckSystem = 1

; Undocumented key
CheckWMI = 1

; Undocumented key
NRPEServer = 1

; Undocumented key
NSCAClient = 1

; Undocumented key
NSClientServer = 1


; Undocumented section
[/settings/default]

; Undocumented key
allowed hosts = xxx.xxx.xxx.xx

; Section for NRPE (NRPEListener.dll) (check_nrpe) protocol options.
[/settings/NRPE/server]
allow arguments = 1

Hope somebody here can help me!


#2

also had this problem. didn’t do any deep research, but I found out that it is due to a new version of check_nrpe that comes with ubuntu 18.04.

./check_nrpe_new -V
NRPE Plugin for Nagios
Version: 3.2.1

./check_nrpe -V
NRPE Plugin for Nagios
Copyright (c) 1999-2008 Ethan Galstad ([email protected])
Version: 2.15

As you can see I’m just using an old check_nrpe version now that I copied from an older Ubuntu installation.

Also tried multiple combinations of

insecure = true
verify mode = none
use ssl = 1

Didn’t work, so I’m using the old check_nrpe binary now.

NSclient-Version is 0.5.2.33


SSL Handshake problem with NSClient++ using NRPE