No Performance Data


#1

Let me start by saying I am new to NSClient and Nagios Core so can I ask that instructions be very explicit.

This is all installed on a 2012 Mac Mini running Fusion 8.5.8

Nagios Core 4 on Ubuntu 16.04.3 LTS Server two Windows Server VM’s one running Server 2016 and SQL 2016 and one running vanilla Server 2012 R2 both using NSClient V0.5.1044.

Nagios appears to be running successfully it can see itself as well as the two windows hosts that have NSClient++ installed

When I look at the services on both the windows hosts I see the following errors for the selected services:

CPU Load - NSClient - ERROR: No Performance data from command: check_CPU Explorer - Unknown Command(s): check_process Uptime - ERROR: No Performance data from command: check_uptime W3SVC -Unknown Command(s): check_service

The commands in the nagios windows.cfg are:

Uptime - check_nt!UPTIME -s "password here" CPU_load - check_nt!CPULOAD!-l 5,80,90 -s "password here" Explorer - check_nt!PROCSTATE!-d SHOWALL -l Explorer.exe -s "Password Here" W3SVC - check_nt!SERVICESTATE!-d SHOWALL -l W3SVC -s “Password Here”

The Nagios.ini file is thus:

If you want to fill this file with all available options run the following command:

nscp settings --generate --add-defaults --load-all

If you want to activate a module and bring in all its options use:

nscp settings --activate-module --add-defaults

For details run: nscp settings --help

; in flight - TODO [/settings/default]

; Undocumented key password = kytlJV6Kab5heMsQFYj

; Undocumented key allowed hosts = 127.0.0.1, 172.16.253.159/32

; in flight - TODO [/settings/NRPE/server]

; Undocumented key verify mode = none

; Undocumented key insecure = true

; in flight - TODO [/modules]

; Undocumented key CheckExternalScripts = disabled

; Undocumented key CheckHelpers = disabled

; Undocumented key CheckNSCP = enabled

; Undocumented key CheckDisk = enabled

; Undocumented key WEBServer = enabled

; Undocumented key CheckSystem = disabled

; Undocumented key NSClientServer = enabled

; Undocumented key CheckEventLog = disabled

; Undocumented key NSCAClient = enabled

; Undocumented key NRPEServer = enabled

NSclient Service is started, running as local Service and access to the desktop is allowed.

One point of note, I cannot browse to the Web Service on either of the windows servers…

Any help appreciated…