NRDP sending to multiple targets


#1

I’m trying to send scheduled checks to multiple NRDP servers. It’s working fine sending to one server, but I can’t get it to work sending to several.

The most straight forward way seem to be to use a commaseparated list of targets in the schedule. This works - ONCE. I get one result sent two each of my two Nagios servers, but then no more until I restart NSclient++ This is what I get in my logs:

2018-04-07 10:12:52: error:c:\source\master\modules\Scheduler\Scheduler.cpp:181:Exception in Failed to register command: : Whoops, invalid payload size: 2 != 1 at line 239 2018-04-07 10:12:52: error:c:\source\master\include\scheduler\simple_scheduler.cpp:230:Task not found: 1

This is relevant bits of my config:

[/settings/scheduler/schedules/Check Memory]

command=check_memory warn=free<5% crit=free<2% perf-config=*(unit:M)

channel = NRDP

target = x,y

[/settings/scheduler/schedules/default]

interval=5s

[/settings/NRDP/client]

hostname =

channel=NRDP

[/settings/NRDP/client/targets/y]

; SECURITY TOKEN - The security token

token =

; RETRIES - Number of times to retry sending.

retries = 3

; TARGET ADDRESS - Target host address

address = http://<yyy.xxx>/nrdp/

; TIMEOUT - Timeout when reading/writing packets to/from sockets.

timeout = 30

;

[/settings/NRDP/client/targets/x]

token =

; RETRIES - Number of times to retry sending.

retries = 3

; TARGET ADDRESS - Target host address

address = http://<xxx.yyy>/nrdp/

Summary

This text will be hidden


#2

Hi there,

I’m having the same issue over here. Windows 2008 and some old 2003 Servers will report once to multiple Nagios host (that is 2 different Nagios Servers) as defined in nsclient.ini on each Windows host. I was wondering if the “send to multiple Nagios hosts” feature only works if all Nagios hosts are online?


#3

Glad someone has run into the same issue.

All two of our nagios hosts are online, we still get the same behaviour - works once when NSclient is started, after that no more updates.

We currently have an ugly workaround going where the 2nd Nagios server get’s a “_” appended to all service names, then we can configure two schedules of the same check, sending to different Nagios hosts.

Obviously not ideal so it would be very nice if this bug (if that is what it is?) could be solved or if there is another undocumented way of making this work.