Performance data parsing issue version x64 [SOLVED]


I am having issues getting back performance data while running external scripts. Have tried putting into quotes, using multiple escapes, but for some reason the data after the pipe symbol doesnt seem to parse out right.

The external script is a bat file. the output is saved to a txt file. I use "type " to sent it back when the script finishes. I have also read the file lines and echoed it out using “for /f “skip=1 eol=; delims=,” %%i in (%tmpfile%) do ( @echo %%i )” logic

Within the nsclient.ini i have “performance data = true” under [/settings/NRPE/server]

The contents within the file are similar to - CRITICAL - Extents (AREA03) above threshold of 75% ^| AREA01=61;65;75;; AREA02=68;65;75;; AREA03=76;65;75;; Extension AREA01 at 61% full
Extension AREA02 at 68% full
Extension AREA03 at 76% full

What I get on the nagios side is - CRITICAL - Extents (AREA03) above threshold of 75% |‘AREA01’=61;65;75 ‘AREA02’=68;65;75 ‘AREA03’=76;65;75 ‘ Extension’=0 ‘AREA01’=0 ‘at’=0 ‘61%’=0 ‘full’=0 ‘ Extension’=0 ‘AREA02’=0 ‘at’=0 ‘68%’=0 ‘full’=0 ‘ Extension’=0 ‘AREA03’=0 ‘at’=0 ‘76%’=0 ‘full’=0

Thank you for any pointers or help,


Found the solution… I was trying the “ignore perfdata” under just the “[/settings/external scripts/scripts]” and expecting it to work. Thanks for the notes on the other topics :blush: Build has an option to not parse performance data from external scripts:

{{{ [/settings/external scripts/scripts/default] ignore perfdata = true }}}