Setting the NRDP token


#1

Hello,

I’m trying to set up NRDP. With the module loaded and the address set up, I can submit results with submit_nrdp if I supply the token when running the command.

I have set up the scheduler to use the NRDP channel and set up a scheduled check, which is submitted, but the only problem is that I had to temporarily disable token checks on the NRDP server.

Changing the log level to trace show this:

2016-11-09 20:13:17: trace:c:\source\master\modules\nrdpclient\nrdp_client.hpp:98: Connecting tuo: protocol: https, host: *****:443, port: 443, path: /nrdp/, timeout: 30, token: , sender:

How can I set up NRDPClient to actually send a token? I monitored registry reads by nscp and saw that it did not request anything resembling the token.

Is this by design or am I missing something?


#2

I found the Issue #331 on github and saw that a fix was committed - thank you. I’ll wait for the next nightly build.

Marton


#3

A show follow-up to anyone who finds this topic: the nightly build published yesterday (14th november, 0.5.0.65) sends the token read from “token” from under the NRDP/client key.

Once again, thank you for the fix.

Marton