[Solved]NSClient 0.5 custom check placement in ini file


Upgrading from 3 and need to migrate our custom checks but I cant’ seem to get them to be active. I restart the service after each edit and see no errors in log file. I think I"m just putting them in the wrong location:

This is my latest guess, have tried modules, external scripts , NRPE/default but nada in all.

[/settings/checksystem] ;Modify defaul check behaviour check_service “exclude=clr_optimization_v4.0.30319_32” “exclude=clr_optimization_v4.0.30319_64”

Thanks John


Anybody got an example nsclient.ini for 0.5 with custom commands in it?

Let me know if more info would be helpful, thanks all John


I have not customized one. But have you tried running nscp test at the commandline and running the test from there? (You can simply type check_service.)


Hey slackr

Yes the syntax is good and the command works, I just need to be able to poll it from Nagios this way:

check_service “exclude=clr_optimization_v4.0.30319_32” “exclude=clr_optimization_v4.0.30319_64” "exclude=swi_update_64" L cli OK: OK: All 142 service(s) are ok.


OK Finally solved this little riddle. Turns out is was not in the nsclient.ini but in the Nagios config. I’ve been using Nagios for a really long time and a bit stuck in my ways so I’ve never sent ARGs over NRPE before now I am and it works great. Who knew? LOL

So for our environment I did:

define command{ command_name check_nrpe_args command_line $USER1$/check_nrpe -H $HOSTADDRESS$ $ARGn$ }

define service{ use generic-service host_name hostA service_description Check Services check_command check_nrpe_args!-c check_service -a “exclude=clr_optimization_v4.0.30319_32” "exclude=clr_optimization_v4.0.30319_64" notification_interval 0 }

John M