Web ui


#1

Hello, this my first post on this forum. I have installed the nsclient++ to a windows pc. I managed to run web interface but every time that i clicked on a tab (Modules, Settings, Queries) asked me for password and i cannot sign in. Only to the first NSClient++ tab i don’t have a problem.

my ini file:

; TODO [/settings/default]

password = password

allowed hosts = 127.0.0.1

; TODO [/settings/NRPE/server] port = 5666 allow arguments = true allow nasty characters = true extended response = false insecure = false use ssl = 1

; Undocumented key ssl options = no-sslv2,no-sslv3

; Undocumented key verify mode = peer-cert

; TODO [/modules]

; Undocumented key CheckExternalScripts = 1

; Undocumented key CheckHelpers = 1

; Undocumented key CheckEventLog = 1

; Undocumented key CheckNSCP = 1

; Undocumented key CheckDisk = 1

; Undocumented key CheckSystem = 1

; Undocumented key NSClientServer = 1

; Undocumented key WEBSErver = 1

; Undocumented key NRPEServer = 1

[/settings/WEB/server] allowed hosts=127.0.0.1 cache allowed hosts=true certificate=${certificate-path}/certificate.pem port=8443

log file:

2018-10-23 13:28:30: error:c:\source\master\modules\WEBServer\WEBServer.cpp:118: Invalid password/token from: 127.0.0.1: 2018-10-23 13:28:31: error:c:\source\master\modules\WEBServer\WEBServer.cpp:118: Invalid password/token from: 127.0.0.1: 2018-10-23 13:49:05: error:c:\source\master\include\socket/connection.hpp:251: Seems we cant agree on SSL: no shared cipher 2018-10-23 13:49:05: error:c:\source\master\include\socket/connection.hpp:252: Please review the insecure options as well as ssl options in settings. 2018-10-23 13:51:15: error:c:\source\master\modules\WEBServer\WEBServer.cpp:118: Invalid password/token from: 127.0.0.1: 2018-10-23 13:52:01: error:c:\source\master\modules\WEBServer\WEBServer.cpp:118: Invalid password/token from: 127.0.0.1:

Any help please?